'Nostale.exe has stopped working'

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • 'Nostale.exe has stopped working'

    Alrighty so, just before i get into everything just gonna let you know a few things :)


    I've been all over the forum and i know that the way to fix this is to re-install nos whenever it happens.
    I also know anti-virus software can cause the removal of the .exe file as that file makes some anti-virus freak out, and i can assure u its not that. :)
    The 'Nostale.exe' file has NOT been removed from my laptop.

    As i mentioned i know the solution is to re-install nos.
    The reason i'm still posting even though i have my solution and that solution works, is because the error 'Nostale.exe has stopped working' happens every single time i turn my laptop on. which of course means, each time i turn my laptop on i have to uninstall nos,re-download it and re-install it.

    This wouldn't be too horrific if there wasn't the added issue of, Nostale and Gameforge refuse to uninstall, meaning i have to go into safe mode and faf around with it there to try get it to remove from my laptop, then return to normal mode and download+install nos once again.

    My question is, has anyone experienced this before? And how did you fix it? (not just the 1 off time, i mean having it happen each time you turn your pc on/off the problem re-surfaces).

    Or If your more knowledgeable about these things then myself and you have some suggestions or ideas :)


    Please bare in mind the information i listed at the start of my post before commenting, thank you :) <3
  • Could you give us a little extra information about your PC? (spec/OS etc)

    I noted above you're using the Gameforge live version, have you tried installing the version without the Gameforge package to see if that creates the same problem?

    Out of interest, what anti-virus are you using?

    If you could take a screenshot of your nostale folder with all of the available files when it refuses to start that'd be helpful. (If you're not comfortable posting that here send me a private message or ticket) it might not be that anything's deleted but clearly something isn't working properly






  • I don't recall how to download without Gameforge. However i used to and if i remember correctly it gave me issues not long ago for whatever reason, (i don't remember what issues, though i think u helped me with it xD @locki).

    As for anti-virus, i was using Norton but it has a habit of deleting random files from games that are perfectly fine. Plus i felt another anti-virus i found was more safe. I stopped using it when this problem first occurred thinking it was Norton, but when i checked, no files i could see were missing. I checked through Norton and it hadn't quarantined/deleted anything either.
    My new anti-virus is Bitdefender, after getting this as a replacement for Norton, the issue with nos was still there. But once again, all the files i could see were still present in my folder and Bitdefender hadn't quarantined/deleted anything.

    As for my laptop... I've ran Nostale beautifully on here for around 2 years. never had this issue before. Besides Norton occasionally freaking out and deleting nostale.exe

    Nostale WILL run on my laptop, but only if i go to safe mode*, uninstall it (and Gameforge), re-download from Nostale website and install it. Then it works, (...until it inevitably breaks again xD).

    *(it wont let me uninstall it outside of safe mode, and yes i can uninstall other things its only nos that does this)





    Some new information though:
    I've been leaving my laptop on while i sleep, as i thought this issue only happened if i turned my laptop off then back on. Because of this, I've come across something else. I woke up, inevitably went to my laptop, went to open nos... -BONG- 'Nostale.exe has stopped working'. So this means turning it off then on isn't the issue. Something happened while i was asleep to suddenly make it not work, (It worked fine before i slept).

    I'm gonna go have fun for 2 hours trying to get nostale off my laptop, re-downloading and installing it.

    If any new information appears or if i find the solution ill post it here :)


    Meanwhile have fun with this weird case you SherlockNosHolmes' (nerds<3)
  • Ok there's nothing immediately obvious to me in the files, other than a few that are a little random in file size compared to what I understood/expected to see.

    If you've managed to uninstall it again yet re-download from here instead Nostale - No Gameforge Live and see how you get on with this version.

    Do you access Nostale from a desktop shortcut?

    It'll be something really simple but spotting it on someone else's PC is huge fun. (On a huge off chance - make sure your date/time/language settings are all correct)
  • Ill try no Gameforge version the next time it acts up.

    As for short cuts ive tried using the little squirrel and going to Gameforge first then selecting Nostale in that window. both end up with the same result.

    And yeah all my settings are correct xD

    Ill post again after i tried the non Gameforge download and/or if anything else occurs.

    ^^
  • Sorry I've been away,

    Is your internet explorer up to date? Try downloading and running CCleaner also, it can be the strangest of things sometimes.

    Otherwise it might be a case of restoring your PC to before the problem started (if that's still possible) and seeing if that cures it. (Make sure you save any documents that need saving).
  • Did all of that when i first got the problem X( and yeah, all up to date.

    Not sure if its related but i now have some 'screen spazzing' also.
    If i try to rotate the screen, the camera erratically flails around in all directions until i let go of the right mouse button.
    (this doesn't occur with anything else except nos and there's nothing wrong with my mouse pad or plug in mouse).

    And then just earlier it progressed to when i zoom in and out on nos.
    When i attempt to zoom in and/or out it zooms erratically in and out and sometimes even zooming out so far i can see the whole map + miles of blank screen which then progresses to keep zooming out, then goes upside down, zooms all the way in and then spins the right way up.

    Because if i close Nostale i cant re-open it again due to the original issue, means i cant just close and re-open to fix it.
    I'm about to try that now however, as its impossible to go from A to B let alone lure in lod or go ic x'D
    So ill leave a message here after i've re-installed nos to see if anything has resolved.

    (i'm hopeful this new issue will be fixed, but i'm sure the old issue will remain as it hasn't worked before xD)
  • Before i do that...

    By spamming the print screen button while trying to rotate my camera, i managed to get a few SS so you can get an idea of what i see if i try to do anything x'D

    Didn't manage to get any of if i try zoom in and out though :/

    I'm going to try changing some options on the options menu when you first open nos before you click play, see if that helps is re-installing fails :)

    (still haven't done re-installation yet but wanted to add the ss ^^)










  • Ok so...

    Before i attempted un-installing, i went to safe mode and tried running nos.. it worked o.o
    so nos only works in safe mode...

    So been as now i'm able to access the options button on the little patch screen thing before you get to the game, (usually id get an error before that screen showed, but in safe mode i don't). I went to options and changed the 'environment' from DirectX to OpenGL, saved it and then left safe mode and logged on m'y pc as normal. After doing that nos allowed me to run it without have to uninstall then re-install it and it worked fine.

    I then discovered at the cost of 70% of the graphics in nostale are broken. things like peoples sp wings being emotes
    People skills coming out as onyx wings.
    I went to ic and i just couldn't see anything x'D it was just a chaotic mess of alt R, alt T, onyx wings and what appeared to be black holes xDD

    To sum up, this method WILL fix the 'Nostale.exe has stopped working' problem
    but you still wont be able to play the game x'D
    Though if your logging in to check baz and/or chat to friends its not too bad.

    About to try changing the 'environment' back to DirectX to see if its fixed, if not i guess i'm back to re-installing or not being able to see anything xD

    Will keep this updated :V
  • Ok so,

    I haven't fixed it but i have a seemingly working solution for anyone else having the same/similar problem.

    If i go to start nos and get the error 'Nostale.Exe has stopped working' (thus not allowing me to get to the patching screen).
    I go to safe mode, (as nostale always works in safe mode). On the patch screen i press the blue options button, change the environment to OpenGL, click save then restart my laptop so i return to normal mode.
    I then open nos, click the blue options button again, and change it back to DirectX, (you'll want to do this as using OpenGL can cause a lot of graphic problems).
    Then Press start and play nos as normal :)

    I don't have to do this each time i turn my laptop on, but it is necessary for me to do it often. (As it breaks again almost every time i turn my laptop back on xD).

    Thinking about it now, you could avoid the issue by simply changing the environment back to OpenGL before turning your PC/Laptop off, Then always changing it back to DirectX to play and so on. Having not tried that yet i can't say that, that works but i cant see why not. It would for the most part eliminate the need to keep restarting in safe mode then back to normal mode.

    Though in my experience, as someone who has multiple characters online at once, i've noticed that it can break even while you're still on nostale.
    Thus not allowing you to open a new one, and being met with the error 'Nostale.exe has stopped working'. Yet somehow your'e still online on another character xD.
    Meaning it might break while your still online, meaning you wont be able to change it back to OpenGL. As once it breaks you cant get to the patch screen outside of safe mode.

    If this method stops working ill post here.
    As an added note, if anyone else has this problem or a very similar one feel free to contact me and ill try help you figure it out :) As we've been shown, sometimes just flicking the graphics type from one to another can fix things.

    Hopefully this method will keep working. And if you have the same problem, hopefully it will work and keep working for you as well xD